Методика переопределения и вызова обработчиков событий обычной формы

Публикация № 16980

Разработка - Практика программирования

203
Каждый из нас хотя бы раз задумывался над тем, как было бы удобно, если бы мы могли переопределять обработчики событий формы, сохраняя возможность вызова старого обработчика независимо от его имени. В этой статье изложен метод, который позволяет реализовать эту возможность.

 

Например, есть конфигурация, которая является доработанной типовой. Вы ее постоянно обновляете и добавляете все больше своих изменений. Обновлять в общем случае с каждым разом становится все труднее и дольше. Заметную часть ваший доработок составляют вставки в начало и конец обработчиков событий формы. А также новые обработчики, которые некоторые еще и назначают в режиме редактирования конфигурации (статически), что дополнительно затрудняет процесс обновления.

Предлагаемый метод состоит в том, чтобы объявить в модуле формы свои обработчики событий, которые будут вызывать старые обработчики и выполнять нужный код до и после этого вызова. Установка новых обработчиков будет производиться в разделе основной программы модуля формы путем вызова общей процедуры, скажем "УстановитьДействиеФормы". Эта процедура в динамически добавленном невидимом элементе формы будет сохранять все старые обработчики для каждого переопределенного события, что позволит довольно просто вызывать их через общую функцию, скажем "ПолучитьСтароеДействиеФормы". Следуя рекомендациям 1С, а также для удобства возьмем за правило: имена новых обработчиков следует формировать как <Префикс>[<ИмяЭлементаФормы>][<ИмяСубэлемента1>...<ИмяСубэлементаN>][<ИмяСобытия>] и параметры их называть стандартно. Субэлементы - элементы внутри элементов формы. Индексы субэлементов означают уровень вложенности.

Случай 1. Добавляем вставку в начало и конец имеющихся в типовой обработчиков событий формы.
Обычно делают примерно так.
// Процедура - обработчик события "ПередОткрытием" формы.
//
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в начало обработчика>
	// }}Добавил TormozIT 23.03.2006

	<Текст тела типового обработчика>

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в конец  обработчика>
	// }}Добавил TormozIT 23.03.2006
 
КонецПроцедуры // ПередОткрытием()

// Процедура - обработчик события "ПриИзменении" поля ввода "Склад".
//
Процедура СкладПриИзмененииВыбора(Элемент)

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в начало обработчика>
	// }}Добавил TormozIT 23.03.2006
	
	<Текст тела типового обработчика>

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в конец  обработчика>
	// }}Добавил TormozIT 23.03.2006

КонецПроцедуры // СкладПриИзменении()

// Процедура - обработчик события "НачалоВыбора" элемента "Товары.ЗаказПокупателя".
// (Событие "НачалоВыбора" поля ввода "ЗаказПокупателя"
// в строке табличной части "Товары")
//
Процедура ТоварыЗаказПокупателяНачалоВыбора(Элемент, СтандартнаяОбработка)
	
	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в начало обработчика>
	// }}Добавил TormozIT 23.03.2006
	
	<Текст тела типового обработчика>

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в конец  обработчика>
	// }}Добавил TormozIT 23.03.2006
	
КонецПроцедуры // ТоварыЗаказПокупателяНачалоВыбора()


// Процедура - обработчик события кнопки "КнопкаВыбратьВвестиХарактеристику" командной панели "ОсновныеДействияФормы".
//
Процедура ОсновныеДействияФормыКнопкаВыбратьВвестиХарактеристику(Кнопка)
	
	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в начало обработчика>
	// }}Добавил TormozIT 23.03.2006
	
	<Текст тела типового обработчика>

	// {{Добавил TormozIT 23.03.2006
	<Текст вставки в конец  обработчика>
	// }}Добавил TormozIT 23.03.2006

КонецПроцедуры // ОсновныеДействияФормыКнопкаВыбратьВвестиХарактеристику()

Все работает и выглядит неплохо. Однако после обновления нам приходится вручную вносить это в новую версию обработчика, если в нем произошли изменения по отношению к старому релизу.

Теперь следует делать так.
// {{Добавил TormozIT 23.03.2006

// Процедура - обработчик события "ПередОткрытием" элемента формы "". 
// 
Процедура ЛксПередОткрытием(Отказ, СтандартнаяОбработка)
	
	<Текст вставки в начало обработчика>
	[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "ПередОткрытием"));]
	<Текст вставки в конец  обработчика>
	
КонецПроцедуры // ЛксПередОткрытием() 

// Процедура - обработчик события "ПриИзменении" элемента формы "Склад".
//
Процедура ЛксСкладПриИзменении(Элемент)
	
	<Текст вставки в начало обработчика>
	[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "ПриИзменении", "Склад"));]
	<Текст вставки в конец  обработчика>
	
КонецПроцедуры // ЛксСкладПриИзменении()

// Процедура - обработчик события "НачалоВыбора" элемента "Товары.ЗаказПокупателя".
// (Событие "НачалоВыбора" поля ввода "ЗаказПокупателя"
// в строке табличной части "Товары")
//
Процедура ЛксТоварыЗаказПокупателяНачалоВыбора(Элемент, СтандартнаяОбработка)
	
	<Текст вставки в начало обработчика>
	[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "НачалоВыбора", "Товары.ЗаказПокупателя"));]
	<Текст вставки в конец  обработчика>
	
КонецПроцедуры // ЛксТоварыЗаказПокупателяНачалоВыбора()

// Процедура - обработчик события кнопки "КнопкаВыбратьВвестиХарактеристику" командной панели "ОсновныеДействияФормы".
//
Процедура ЛксОсновныеДействияФормыКнопкаВыбратьВвестиХарактеристику(Кнопка)

	<Текст вставки в начало обработчика>
	[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, , "ОсновныеДействияФормы.КнопкаВыбратьВвестиХарактеристику"));]
	<Текст вставки в конец  обработчика>

КонецПроцедуры // ЛксОсновныеДействияФормыКнопкаВыбратьВвестиХарактеристику()

ЛксУстановитьДействиеФормы(ЭтаФорма, "ПередОткрытием");
ЛксУстановитьДействиеФормы(ЭтаФорма, "ПриИзменении"  , "Склад");
ЛксУстановитьДействиеФормы(ЭтаФорма, "НачалоВыбора"  , "Товары.ЗаказПокупателя");
ЛксУстановитьДействиеФормы(ЭтаФорма,				 , "ОсновныеДействияФормы.КнопкаВыбратьВвестиХарактеристику");

// }}Добавил TormozIT 23.03.2006 

//////////////////////////////////////////////////////////////////////////////// 
// ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ


Таким образом, при обновлении в общем случае нам нужно будет всего лишь добавить один блок в раздел операторов основной программы. Строго говоря, этот блок нужно поместить в самый конец этого раздела, т.к. в нем могут присутствовать конкурентные назначения обработчиков. Однако в типовых конфигурациях это встречается крайне редко. Альтернативным вариантом является вынесение установки всех обработчиков, кроме ПередОткрытием, в новый обработчик ПередОткрытием.
Так как раздел основной программы модуля формы почти никогда не меняется, то для него в настройке объединения просто уберем галочку, чем полностью исключим ручную правку модуля формы после обновления.

Случай 2. Добавляем новый обработчик события элемента формы.
Обычно делают примерно так.
// {{Добавил TormozIT 23.03.2006

// Процедура - обработчик события "ПриИзменении" элемента формы "Склад".
//
Процедура СкладПриИзменении(Элемент)
	
	<Текст начала своего обработчика>
	<Текст конца  своего обработчика>
	
КонецПроцедуры // СкладПриИзменении()

// }}Добавил TormozIT 23.03.2006

Все работает и выглядит хорошо.
Но подумайте, что будет, если в новом релизе будет добавлен в режиме редактирования конфигурации (статически) связанный обработчик для того же события и, возможно, что еще хуже, с таким же именем!

Как следует поступать в этом случае?
Опять по той же схеме.
// {{Добавил TormozIT 23.03.2006

// Процедура - обработчик события "ПриИзменении" элемента формы "Склад".
//
Процедура ЛксСкладПриИзменении(Элемент)
	
	<Текст начала обработчика>
	[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "ПриИзменении", "Склад"));]
	<Текст конца  обработчика>
	
КонецПроцедуры // ЛксСкладПриИзменении()

ЛксУстановитьДействиеФормы(ЭтаФорма, "ПриИзменении"  , "Склад");
// }}Добавил TormozIT 23.03.2006

//////////////////////////////////////////////////////////////////////////////// 
// ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ

Теперь уже нам не страшен добавленный в одном из будущих релизов обработчик этого события и его имя! Как только он появится, наш обработчик будет его вызывать там, где мы прописали.

Отдельно хочется упомянуть о новых элементах формы. Если вы добавили в форму свой элемент и хотите сделать для него обработчик какого-нибудь события, то имеет смысл и в этом случае поступать так же. Ведь в новом релизе могут добавить элемент формы того же функционального назначения. Если он будет с тем же именем, что и ваш, то вам после обновления даже ничего менять не придется. А если имя будет другое, то просто нужно будет исправить название вашего обработчика и параметр в вызове его установки.

Необходимые процедуры и функции общего модуля
Сначала процедура переопределения события.
Для хранения старых обработчиков событий мы используем хитрость, предложенную Гением 1С http://kb.mista.ru/article.php?id=101.
Суть ее состоит в динамическом добавлении нулевых размеров служебного элемента формы для хранения в нем списка значений в свойстве СписокВыбора. Т.е. сначала проверяем есть ли элемент формы с заданным именем (в примере "рСтарыеОбработчики"). Если его нет, то создаем. Затем получаем обработчик нужного действия формы или элемента формы. Сохраняем его в свойстве СписокВыбора служебного элемента формы. Устанавливаем новый обработчик, имя которого формируем по нашему правилу <Префикс> [ + <ИмяЭлементаФормы>] [ + <ИмяСубэлемента1> ... + <ИмяСубэлементаN>] [ + <ИмяСобытия>]. Параметр "пЛиИсключительное" отвечает за проверку наличия старого обработчика. Такая проверка может понадобится для назначения обработчиков, которые не вызывают старый обработчик (например, НачалоВыбора). Параметр "пПсевдонимЭлементаФормы" позволяет нам назначить нескольким однотипным событиям один обработчик через указание одинакового псевдонима при установке обработчика.
// Переопределяет обработчик события формы.
// Сохраняет штатный обработчик события внутри формы и устанавливает новый.
//
// Параметры:
//  пФорма	   – Форма – форма;
//  *пИмяСобытия – Строка – имя события;
//  *пИмяЭлементаФормы – Строка – полное имя элемента формы.
//  *пЛиИсключительное – Булево – сообщать о наличии старого обработчика;
//  *пПсевдонимЭлементаФормы – Строка – псевдоним элемента формы, используется для назначения одного обработчика
//			   для нескольких однотипных событий формы.
//
Процедура ЛксУстановитьДействиеФормы(пФорма, пИмяСобытия = "", пИмяЭлементаФормы = "",
									 пЛиИсключительное = Ложь, пПсевдонимЭлементаФормы = "") Экспорт
	
	Если пИмяЭлементаФормы <> "" Тогда
		МассивФрагментов = ЛксПолучитьМассивИзСтрокиСРазделителем(пИмяЭлементаФормы);
		ИмяЭлементаФормы = МассивФрагментов[0];
		Объект = пФорма.ЭлементыФормы[ИмяЭлементаФормы];
		Если МассивФрагментов.Количество() > 1 Тогда 
			ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
			Если ТипЗнч(Объект) = Тип("ТабличноеПоле") Тогда 
				Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
			ИначеЕсли ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда 
				Объект = Объект.Кнопки[МассивФрагментов[1]];				
			КонецЕсли;
		КонецЕсли;
	Иначе
		Объект = пФорма;
		ИмяЭлементаФормы = "";
	КонецЕсли;
	
	ТекстМаркера = "рСтарыеОбработчики";
	Если пФорма.ЭлементыФормы.Найти(ТекстМаркера) = Неопределено Тогда
		пФорма.ЭлементыФормы.Добавить(Тип("ПолеВвода"), ТекстМаркера, Ложь);
	КонецЕсли;
	
	Если пПсевдонимЭлементаФормы <> "" Тогда 
		ПолноеИмяСобытия = пПсевдонимЭлементаФормы + пИмяСобытия;
	Иначе
		ПолноеИмяСобытия = ИмяЭлементаФормы		+ пИмяСобытия;
	КонецЕсли;
	
	Если ТипЗнч(Объект) = Тип("КнопкаКоманднойПанели") Тогда
		СтароеДействие = Объект.Действие;
	Иначе
		СтароеДействие = Объект.ПолучитьДействие(пИмяСобытия);
	КонецЕсли;
	
	Если пЛиИсключительное и СтароеДействие <> Неопределено Тогда 
		Сообщить("Конфликт обработчиков события """ + пИмяСобытия + """ объекта """ + Строка(Объект) + """",
				 СтатусСообщения.Важное);
	КонецЕсли;
	НовоеДействие = Новый Действие("Лкс" + ПолноеИмяСобытия);
	
	// Для отладки здесь следует отключать попытку. Она используется для назначения унифицированных обработчиков,
	// наличие которых не является обязательным.
	Попытка
		Если ТипЗнч(Объект) = Тип("КнопкаКоманднойПанели") Тогда
			Объект.Действие = НовоеДействие;
		Иначе
			Объект.УстановитьДействие(пИмяСобытия, НовоеДействие);
		КонецЕсли;
	Исключение
		Возврат;
	КонецПопытки;
	
	СписокСоответствияОбработчиков = пФорма.ЭлементыФормы.рСтарыеОбработчики.СписокВыбора;
	СписокСоответствияОбработчиков.Добавить(ИмяЭлементаФормы + "." + пИмяСобытия, СтароеДействие);

КонецПроцедуры // ЛксУстановитьДействиеФормы()

Теперь функция для получения выражения на языке 1С, которое можно выполнить в модуле формы с целью запуска старого обработчика и передачи ему нужных параметров. В случае, если старого обработчика не было назначено для события, функция вернет пустую строку. Сначала приведена вспомогательная функция получения строки аргументов.
// Получаем стандартную строку аргументов для выполнения вызова обработчика события формы.
//
// Параметры:
//  пОбъект	  – Форма, ЭлементФормы – объект события;
//  *пИмяСобытия – Строка – имя события.
//
// Возвращаемое значение:
//			   – Строка – строка аргументов вида "([Аргумент1][, Аргумент2, ... , АргументN]);",
//			   где аргументы имеют свои стандартные названия для каждого события.
//
Функция ЛксПолучитьАргументыДействияФормы(пОбъект, пИмяСобытия = "")

	Аргументы = "";
	Если ТипЗнч(пОбъект) = Тип("КнопкаКоманднойПанели") Тогда
		// Это действие кнопки командной панели формы
		Аргументы = "(Кнопка)";		
	ИначеЕсли ТипЗнч(пОбъект) = Тип("Форма") Тогда
		// Это событие формы
		Попытка
			ОбъектОсновнойРеквизитФормы = пОбъект.ЭтотОбъект;
		Исключение
			ОбъектОсновнойРеквизитФормы = Неопределено;
		КонецПопытки;
		Если Аргументы = "" Тогда 
			Если	  пИмяСобытия = "ВнешнееСобытие" Тогда 
				Аргументы = "(Источник, Событие, Данные)";
			ИначеЕсли пИмяСобытия = "ОбработкаАктивизацииОбъекта" Тогда 
				Аргументы = "(АктивныйОбъект, Источник)";
			ИначеЕсли пИмяСобытия = "ОбработкаВыбора" Тогда 
				Аргументы = "(ЗначениеВыбора, Источник)";
			ИначеЕсли пИмяСобытия = "ОбработкаЗаписиНовогоОбъекта" Тогда 
				Аргументы = "(Объект, Источник)";
			ИначеЕсли пИмяСобытия = "ОбработкаОповещения" Тогда 
				Аргументы = "(ИмяСобытия, Параметр, Источник)";
			ИначеЕсли пИмяСобытия = "ПередЗакрытием" Тогда 
				Аргументы = "(Отказ, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ПередЗаписью" Тогда 
				Если ЛксПолучитьКорневойТипКонфигурации(ОбъектОсновнойРеквизитФормы) = "Документ" Тогда
					Аргументы = "(Отказ, РежимЗаписи, РежимПроведения)";
				Иначе
					Аргументы = "(Отказ)";
				КонецЕсли;
			ИначеЕсли пИмяСобытия = "ПередОткрытием" Тогда 
				Аргументы = "(Отказ, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ПриЗаписи" Тогда 
				Аргументы = "(Отказ)";
			ИначеЕсли пИмяСобытия = "ПриПовторномОткрытии" Тогда 
				Аргументы = "(СтандартнаяОбработка)";
			Иначе
				Аргументы = "()";
			КонецЕсли;
		КонецЕсли;		
	Иначе
		// Это событие элемента формы
		Если ТипЗнч(пОбъект) = Тип("ТабличноеПоле") Тогда
			Если	  пИмяСобытия = "Выбор" Тогда 
				Аргументы = "(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "Перетаскивание" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)";
			ИначеЕсли пИмяСобытия = "ПроверкаПеретаскивания" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)";
			КонецЕсли;
		ИначеЕсли ТипЗнч(пОбъект) = Тип("ТабличныйДокумент") Тогда
			Если	  пИмяСобытия = "Выбор" Тогда 
				Аргументы = "(Элемент, Область, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "Перетаскивание" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Область)";
			ИначеЕсли пИмяСобытия = "ПроверкаПеретаскивания" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Область)";
			КонецЕсли;
		КонецЕсли;
		Если Аргументы = "" Тогда 
			Если	  пИмяСобытия = "АвтоПодборТекста" Тогда 
				Аргументы = "(Элемент, Текст, ТекстАвтоПодбора, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "НачалоВыбора" Тогда 
				Аргументы = "(Элемент, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "НачалоПеретаскивания" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ОбработкаВыбора" Тогда 
				Аргументы = "(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ОбработкаЗаписиНовогоОбъекта" Тогда 
				Аргументы = "(Элемент, Объект, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ОбработкаРасшифровки" Тогда 
				Аргументы = "(Элемент, Расшифровка, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ОкончаниеВводаТекста" Тогда 
				Аргументы = "(Элемент, Текст, Значение, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ОкончаниеПеретаскивания" Тогда 
				Аргументы = "(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "Открытие" Тогда 
				Аргументы = "(Элемент, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "Очистка" Тогда 
				Аргументы = "(Элемент, СтандартнаяОбработка)";
			ИначеЕсли пИмяСобытия = "ПередНачаломДобавления" Тогда 
				Аргументы = "(Элемент, Отказ, Копирование)";
			ИначеЕсли пИмяСобытия = "ПередНачаломИзменения" Тогда 
				Аргументы = "(Элемент, Отказ)";
			ИначеЕсли пИмяСобытия = "ПередОкончаниемРедактирования" Тогда 
				Аргументы = "(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)";
			ИначеЕсли пИмяСобытия = "ПередУдалением" Тогда 
				Аргументы = "(Элемент, Отказ)";
			ИначеЕсли пИмяСобытия = "ПриВыводеСтроки" Тогда 
				Аргументы = "(Элемент, ОформлениеСтроки, ДанныеСтроки)";
			ИначеЕсли пИмяСобытия = "ПриИзмененииСодержимогоОбласти" Тогда 
				Аргументы = "(Элемент, Область)";
			ИначеЕсли пИмяСобытия = "ПриНачалеРедактирования" Тогда 
				Аргументы = "(Элемент, НоваяСтрока, Копирование)";
			ИначеЕсли пИмяСобытия = "ПриОкончанииРедактирования" Тогда 
				Аргументы = "(Элемент, НоваяСтрока, ОтменаРедактирования)";
			ИначеЕсли пИмяСобытия = "ПриОкончанииРедактированияИнтервала" Тогда 
				Аргументы = "(Элемент, Интервал, Отмена)";
			ИначеЕсли пИмяСобытия = "ПриПолученииДанных" Тогда 
				Аргументы = "(Элемент, ОформленияСтрок)";
			ИначеЕсли пИмяСобытия = "ПриСменеСтраницы" Тогда 
				Аргументы = "(Элемент, ТекущаяСтраница)";
			ИначеЕсли пИмяСобытия = "Регулирование" Тогда 
				Аргументы = "(Элемент, Направление, СтандартнаяОбработка)";
			Иначе
				Аргументы = "(Элемент)";
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	Возврат Аргументы + ";";

КонецФункции // ЛксПолучитьАргументыДействияФормы()

// Получаем текст для выполнения вызова старого обработчика события формы или элемента формы.
//
// Параметры:
//  пФорма	   – Форма – форма;
//  *пИмяСобытия – Строка – имя события;
//  *пИмяЭлементаФормы – Строка – полное имя элемента формы.
//
// Возвращаемое значение:
//			   – Строка – текст для выполнения.
//
Функция ЛксПолучитьСтароеДействиеФормы(пФорма, пИмяСобытия = "", пИмяЭлементаФормы = "") Экспорт
	
	Если пИмяЭлементаФормы <> "" Тогда 
		МассивФрагментов = ЛксПолучитьМассивИзСтрокиСРазделителем(пИмяЭлементаФормы);
		ИмяЭлементаФормы = МассивФрагментов[0];
		Объект = пФорма.ЭлементыФормы[ИмяЭлементаФормы];
		Если МассивФрагментов.Количество() > 1 Тогда 
			ИмяЭлементаФормы = ИмяЭлементаФормы + МассивФрагментов[1];
			Если ТипЗнч(Объект) = Тип("ТабличноеПоле") Тогда 
				Объект = Объект.Колонки[МассивФрагментов[1]].ЭлементУправления;
			ИначеЕсли ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда 
				Объект = Объект.Кнопки[МассивФрагментов[1]];				
			КонецЕсли;
		КонецЕсли;
	Иначе
		ИмяЭлементаФормы = "";
		Объект = пФорма;
	КонецЕсли;
	
	СтарыйОбработчик = "";
	СписокСоответствияОбработчиков = пФорма.ЭлементыФормы.рСтарыеОбработчики.СписокВыбора;
	ЭлементСписка = СписокСоответствияОбработчиков.НайтиПоЗначению(ИмяЭлементаФормы + "." + пИмяСобытия);
	Если ЭлементСписка <> Неопределено Тогда 
		СтарыйОбработчик = ЭлементСписка.Представление;
	КонецЕсли;
	Если СтарыйОбработчик <> "" Тогда 
		СтарыйОбработчик = СтарыйОбработчик + ЛксПолучитьАргументыДействияФормы(Объект, пИмяСобытия);
	КонецЕсли;
	Возврат СтарыйОбработчик;

КонецФункции // ЛксПолучитьСтароеДействиеФормы()

Теперь функция для получения выражения на языке 1С, которое можно выполнить в модуле формы с целью запуска актуального обработчика и передачи ему нужных параметров. В случае, если актуального обработчика не было назначено для события, функция вернет пустую строку.
// Получаем текст для выполнения вызова обработчика события формы.
// Текст включает инициализацию параметра Элемент для событий элементов формы.
//
// Параметры:
//  пФорма	   – Форма – форма;
//  *пИмяСобытия – Строка – имя события;
//  *пИмяЭлементаФормы – Строка – полное имя элемента формы.
//
// Возвращаемое значение:
//			   – Строка – текст для выполнения.
//
Функция ЛксПолучитьДействиеФормы(пФорма, пИмяСобытия = "", пИмяЭлементаФормы = "") Экспорт

	// Явное "определение" типа переменных.
	Если Ложь Тогда
		пФорма = ПолучитьОбщуюФорму(0);
	КонецЕсли;
	
	Если пИмяЭлементаФормы <> "" Тогда 
		МассивФрагментов = ЛксПолучитьМассивИзСтрокиСРазделителем(пИмяЭлементаФормы);
		Объект = пФорма.ЭлементыФормы[МассивФрагментов[0]];
		Если МассивФрагментов.Количество() > 1 Тогда
			ИмяСубэлемента = МассивФрагментов[1];
			ИмяЭлементаФормы = ИмяЭлементаФормы + ИмяСубэлемента;
			Если ТипЗнч(Объект) = Тип("ТабличноеПоле") Тогда 
				Объект = Объект.Колонки[ИмяСубэлемента].ЭлементУправления;
				УстановкаПараметров = "Элемент = ЭлементыФормы." + ИмяЭлементаФормы + "Колонки[" 
						   + ИмяСубэлемента + "].ЭлементУправления;" + Символы.ПС;
			ИначеЕсли ТипЗнч(Объект) = Тип("КоманднаяПанель") Тогда 
				Объект = Объект.Кнопки[ИмяСубэлемента];				
				УстановкаПараметров = "Кнопка = ЭлементыФормы." + ИмяЭлементаФормы + "Кнопки[" 
						   + ИмяСубэлемента + "];" + Символы.ПС;
			Иначе
				Сообщить("Неизвестный тип элемента """ + ТипЗнч(Объект) + """ с  субэлементом """ 
					   + ИмяСубэлемента + """ при получении действия формы");
			КонецЕсли;
		Иначе
			УстановкаПараметров = "Элемент = ЭлементыФормы." + пИмяЭлементаФормы + ";" + Символы.ПС;
		КонецЕсли;
	Иначе
		Объект = пФорма;
	КонецЕсли;
	
	Обработчик = Строка(Объект.ПолучитьДействие(пИмяСобытия));
	Если Обработчик <> "" Тогда 
		Обработчик = УстановкаПараметров + Обработчик + ЛксПолучитьАргументыДействияФормы(Объект, пИмяСобытия)
				   + Символы.ПС;
	КонецЕсли;
	Возврат Обработчик;

КонецФункции // ЛксПолучитьДействиеФормы()

Ну и вспомогательные функции парсинга (разбора) строки и получения типа ссылки.
// Функция разбивает строку разделителем.
// 
// Параметры:
//  пСтрока	  - Строка - которую разбиваем;
//  *пРазделитель - Строка - символ-разделитель.
//
// Возвращаемое значение:
//			   - Массив - содержащий фрагменты, на которые разбивает строку разделитель.
//
Функция ЛксПолучитьМассивИзСтрокиСРазделителем(пСтрока, пРазделитель = ".") Экспорт
	
	Массив = Новый Массив;
	лСтрока = СтрЗаменить(пСтрока, пРазделитель, Символы.ПС);
	Для Счетчик = 1 По СтрЧислоСтрок(лСтрока) Цикл 
		Массив.Добавить(СтрПолучитьСтроку(лСтрока, Счетчик));
	КонецЦикла;
	Возврат Массив;
	
КонецФункции // ЛксПолучитьМассивИзСтрокиСРазделителем()

// Определяет корневой тип конфигурации.
//
// Параметры:
//  пЗначение	– Произвольный – проверяемое значение.
//
// Возвращаемое значение:
//  Строка	   – имя корневого типа конфигурации метаданных;
//  Неопределено – значение не является объектом коневого типа конфигурации.
//
Функция ЛксПолучитьКорневойТипКонфигурации(пЗначение) Экспорт

	ОбъектМетаданных = Метаданные.НайтиПоТипу(ТипЗнч(пЗначение));
	Если ОбъектМетаданных <> Неопределено Тогда 
		МассивФрагментов = ЛксПолучитьМассивИзСтрокиСРазделителем(ОбъектМетаданных.ПолноеИмя());
		Если МассивФрагментов.Количество() = 2 Тогда 
			Возврат МассивФрагментов[0];
		Иначе
			// Ссылка на субобъект
		КонецЕсли;
	КонецЕсли;
	Возврат Неопределено;
	
КонецФункции // ЛксПолучитьКорневойТипКонфигурации()


Как программно вызвать обработчик события формы из ее модуля, не привязываясь к имени обработчика?
В этом случае нам поможет функция ЛксПолучитьДействиеФормы(), которая возвращает текст для вызова обработчика события. Перед выполнением самого вызова необходимо инициализировать параметры обработчика.

Общий случай:
<Инициализация параметров вызова обработчика события>
Выполнить(ЛксПолучитьДействиеФормы(Форма, ИмяСобытия, ИмяЭлементаФормы));

Пример вызова события НачалоВыбора для элемента формы с именем "Склад":
СтандартнаяОбработка = Ложь;
Выполнить(ЛксПолучитьДействиеФормы(Форма, "НачалоВыбора", "Склад"));


Как программно вызвать обработчик события формы из любого модуля, не привязываясь к имени обработчика?
Для этого трюка в модуле формы конечно придется разместить метод, выполняющих произвольный код через метод Выполнить:
// Выполняет выражение. Используется извне для программного вызова событий и выполнения
// приватных методов. В параметр необходимо помещать не только вызов метода, но и инициализацию
// его параметров.
// 
// Параметры:
//  пВыражение - Строка - которую нужно выполнить.
//
Процедура ЛксВыполнить(пВыражение) Экспорт
	Выполнить(пВыражение);
КонецПроцедуры // ЛксВыполнить()

Инициализацию парамертов обработчика события естественно необходимо размещать в параметре "Выражение".

Пример вызова обработчика события НачалоВыбора для элемента формы с именем "Склад":
Выражение = "СтандартнаяОбработка = Ложь;" + Символы.ПС;
Выражение = Выражение + ЛксПолучитьДействиеФормы(Форма, "НачалоВыбора", "Склад");
Форма.ЛксВыполнить(Выражение);


Шаблоны
Для облегчения создания новых обработчиков разумно написать общий шаблон. Вот мой:
// Процедура - обработчик события "" элемента формы "".
//
<?>Процедура Лкс<?"Объект"><?><?"Событие">()

	<?>
	Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "Событие">", "Объект">"));	

КонецПроцедуры // Лкс()

ЛксУстановитьДействиеФормы(ЭтаФорма, "Событие">", "Объект">");

Также можно написать и частные шаблоны для еще большего ускорения разработки. Тогда вам даже не придется искать/вспоминать стандартную строку параметров обработчика события.

Например шаблон для обработчика события ПриИзменении:

// Процедура - обработчик события "ПриИзменении" элемента формы "".
//
Процедура Лкс<?"Объект">ПриИзменении(Элемент)

	Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "ПриИзменении", "Объект">"));	
	<?>

КонецПроцедуры // ЛксПриИзменении()

ЛксУстановитьДействиеФормы(ЭтаФорма, "ПриИзменении", "Объект">");


А вот шаблон для обработчика события кнопки:

// Процедура - обработчик события кнопки "" командной панели "".
//
Процедура Лкс<?"Командная панель"><?><?"Кнопка">(Кнопка)

	Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "", "Командная панель">.Кнопка">"));	
	<?>

КонецПроцедуры // Лкс()

ЛксУстановитьДействиеФормы(ЭтаФорма, "", "Командная панель">.Кнопка">");


Итоги
Я успешно применяю данную методику на практике. Реализованы унифицированные обработчики однотипных событий формы, что позволяет не привязываться к имени элемента формы. Многие типы событий обрабатываются почти глобально при сохранении вызова типовых и наличии новых обрабочтиков.

Думаю, что описанная методика заслуживает платформенной реализации.

 

http://kb.mista.ru/article.php?id=268

203

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. цыпа 02.06.09 15:14 Сейчас в теме
подскажите,как найти центр в геометрической схеме ограничивающего прямоугольника?
2. tormozit 5590 02.06.09 15:25 Сейчас в теме
8. Поручик 4328 16.09.10 22:28 Сейчас в теме
(2) Для управляемых форм 8.2. не пробовал портировать?
12. HIgor 19 24.10.12 10:01 Сейчас в теме
(8) Поручик, присоединяюсь. Кто знает подобное решение для управляемых форм?
13. stalker18 09.11.12 17:37 Сейчас в теме
(12) HIgor, поддерживаю, очень интересует подобная схема для управляемых форм
16. pbazeliuk 10.02.13 11:50 Сейчас в теме
(8) Поручик, (12) HIgor, (13) stalker18, (15) alekseies, вот для УФ http://infostart.ru/public/169131/. Метод похож на та этот. Спасибо автору за идею и малость кода.
27. dima_home 107 11.05.18 13:56 Сейчас в теме
(1)
центр в геометрической схеме ограничивающего прямоугольника

Центр = Половина длины сторон ограничивающего прямоугольника. ;)
3. vheart 25.07.09 10:12 Сейчас в теме
А в чем преимущество данного функционала перед возможностью платформы переопределять обработчики событий (only v8.1). Ведь можно назначать обработчики для событий прикладных объектов, прикладных объектов, наборов записей и СОМ - объектов.
4. KapasMordorov 25.07.09 10:18 Сейчас в теме
(3)
Вообще-то статья о формах. Форма - прикладной объект?
5. inse0f 25.07.09 12:22 Сейчас в теме
юзаю уже давно респект, но вчера наткнулся на баг небольшой, в событии ПриИзмененииФлажка
6. Поручик 4328 10.01.10 21:16 Сейчас в теме
Лучше поздно, чем никогда.
Сам применил эту методику в рабочей конфе. Спасибо автору.
7. bashhhh 25 12.01.10 07:39 Сейчас в теме
Внедряю УПП. Попоробую эту методику, т.к. события форм максимально автоматизируются. Только вот вопрос вида форм для разных ролей этой методикой не решить, скорее всего будет несколько форм документов для различных должностей. :?:

+1 Шпасиба!
9. amiralnar 8 03.12.10 12:14 Сейчас в теме
Не работает на подменю:
ЛксУстановитьДействиеФормы(ЭтаФорма, , "ДействияФормы.Подменю2.ЭлектронныеПисьмаПлюсКонтактныеЛица");
10. HIgor 19 19.01.12 09:17 Сейчас в теме
Классное решение. Правда не сразу разобрался, но сейчас доволен как удав :-) (УПП 8.2 работает)
11. script 206 13.09.12 16:12 Сейчас в теме
Пожалуйста продемонтрируйте данную технологию на практическом примере.
Описание методики до меня начало доходить только после 2 прочтения. И все равно я не понял
как будут переопределяться динамичиские обработчики событий, назначенные программно (напр. меню кнопки "Печать","Заполнить" или "Вид операции" в документах типовых конфигураций).
Очень прошу описать выполнение действий для простой задачи, например:
1) Ручное добавление реквизита "НаименованиеДляНалоговойНакладной" в справочник "Контрагенты"
и заполнение данного реквизита при изменении заначения в реквизите "Наименование".
По аналогии с реквизитом "Полное наименование".
2) В документе "Реализация товаров и услуг" в процедуре ПриОткрытии() вызывается процедура
РаботаСДиалогами.УстановитьПодменюВыбораВидаОперации(,......,Новый Действие("ДействияФормыДействиеУстановитьОперацию"));
Цель задачи: необходимо переопределить обработчик "ДействияФормыДействиеУстановитьОперацию".
В новом обработчике необходимо реализовать вывод некоторой картинки-пиктограммы, которая отображалась бы перед наименованием вида опреации.
14. script 206 29.01.13 02:38 Сейчас в теме
БРАВО!!! Это просто круть.
15. alekseies 30.01.13 12:47 Сейчас в теме
хорошо бы реализовать подобное для управляемых форм 8.2................
17. LexSeIch 202 11.02.13 07:13 Сейчас в теме
Мир этому дому. Спасибо за статью. Чужой опыт, всегда полезен - указывает возможный путь и решение.
18. mikhailovaew 126 13.02.13 14:09 Сейчас в теме
Можно попросить Вас отформатировать программный текст? Сейчас он растянут, читается тяжело
(
особенно
перенос
скобок
на новую
строчку
)
19. tormozit 5590 13.02.13 14:21 Сейчас в теме
(18) К сожалению вручную это большие трудозатраты. Как это сделать автоматизировано, у меня пока нет идей. Сломалось по вине движка сайта. Я лишь добавил ссылку на версию методики для управляемых форм. После сохранения все форматирование сломалось. Я обращался к модератору с просьбой помочь, но он пока не отреагировал на нее =(
20. tormozit 5590 25.02.13 10:22 Сейчас в теме
Тех. поддержка восстановила форматирование содержимого публикации.
21. alekseies 27.02.13 13:46 Сейчас в теме
для УФ http://infostart.ru/public/169131/. Метод похож , но более трудоемк для обновления на новые конфигурации .............
22. tormozit 5590 27.02.13 14:51 Сейчас в теме
(21) Я все надеялся в самой публикации указать эту ссылку, но к сожалению при попытке отредактировать публикацию в ней ломается все оформление программного кода. Видимо теперь она навсегда останется в текущем виде.
23. mikhailv 19 02.04.15 16:01 Сейчас в теме
Шаблоны в конце статьи не читабельны. Здесь зеркало статьи с нормальными шаблонами: http://kb.mista.ru/article.php?id=268
И еще: долго с коллегами думали, что же делает, например, код:
[Выполнить(ЛксПолучитьСтароеДействиеФормы(ЭтаФорма, "ПередОткрытием"));]

Оказалось, что квадратные здесь - просто для красоты ^.^ Может быть, хотя бы в статье-зеркале уберёте, раз эта не недактируется?
24. tormozit 5590 03.04.15 09:14 Сейчас в теме
Квадратные скобки обозначают необязательный фрагмент.
25. Патриот 236 20.02.18 19:55 Сейчас в теме
(0), спасибо.
Потребовалось добавить во все формы конфы немного программного кода. В платформе есть возможность выгружать загружать файлы конфы. Чтоб велосипеды не городить да время сэкономить, не подскажите, нет ли обработки, позволяющей во все формы конфы добавить некий код? Может даже с указанием, в какую процедуру надо код вопхнуть...
26. script 206 11.05.18 00:04 Сейчас в теме
Сколько лет прошло, а методика жива и работает
28. UNIT68RUS 08.05.19 09:35 Сейчас в теме
По обработке можно выложить скрин экрана обработки?
29. Cерый 14 16.07.19 18:55 Сейчас в теме
По образцу Вашей статьи мной решалась задача вызова обработчика "ПриИзменении" реквизита формы документа в процедуре общего модуля;
оказалось, что для обработчиков, не объявленных как экспортные, возвращается ПолучитьДействие (отличное от Неопределено),
но попытка выполнения их вне формы выдает ошибку: Метод объекта не обнаружен, объявление их экспортными ошибку устраняло
(8.3.9, режим совместимости Версия 8.2.16, обычные формы).

Благодарю за статью.
30. tormozit 5590 08.08.19 07:17 Сейчас в теме
Обработчик ПриИзменении для поля формы часто удобнее вызывать через https://infostart.ru/public/16985/
triviumfan; +1 Ответить
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9552    ids79    42       

Три костыля. Сказ про фокусы в коде 121

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7593    YPermitin    67       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7936    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9905    ids79    22       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9604    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    8927    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8410    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6114    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 190

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17033    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 175

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11341    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    16988    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9613    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4698    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7207    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16134    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12546    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12656    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15188    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12536    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21104    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 117

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18671    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19263    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20643    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20295    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14436    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    20979    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19153    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24165    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21059    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16822    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11232    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24072    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35340    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25714    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21206    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 717

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136750    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22521    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 65

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20936    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23885    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24375    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46434    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 126

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18091    vardeg    31